ExploreHD - Extreme latency, freeze and pixilisation

I am currently building a new ROV and in this testphase I have connected the RPi4and Navigator from Blue Robotics together. They are in turn connected to the PC via ethernet cable.
I have tested the Blue Robotic LowLight HD usb camera and it worked as expected, no problems there.
When I connect the ExploreHD (After disconnecting the BR Cam) the video shows latancy, half way freezes and goes into large pixels when I move the camera.
When holding the camera still, the image clears up.

Any suggestion on how to go about this problem ?

1 Like


Can you send us a video of what you are describing? The pixelation you are describing may be a problem with your PC decoding H264. Also let us know how you are viewing the video streams. What software you are using and how many videos you are trying to stream and view at once.


The forum did not accept a video upload.
My setup i a brand new PC Connected to a Bluerobotic RPi4 with Navigator via an Ethernet cable. The only thing connected is one! HD cam for testing. I have tested the same setup with Bluerobotic usb hd camera and that works fine. See the spec for the pc on the picture.

And this is how the picture looks when moving he camera or objects in front of the camera.

I notice on the order you have 2 exploreHDs. Does this problem appear on both or just one of the cameras?

I have tested both cameras and they are both behaving the same. Again, using the BlueRobotic usb camera is going very well.
The camera is configured as shown in the below picture and set to 50Hz as the power grid here in Norway. I also have some sample videos but are not allowed to upload…

Note: I am not connected through the Multiplexer, but directly to the USB in the RPi4

If both cameras are experiencing the same issue, it is most likely not a hardware problem. Can you try streaming just one camera. I also see that it is using 720 at 25 FPS, maybe try 1080P with 30 FPS. If you can, send me a video sample of it using Google Drive or similar platform.


Joseph, I have only been streaming one camera at the time, never both at the same time. I will send you a video at 1080P x 30FPS

Thanks for your patience.

In QGroundControl, go to Application Settings and I would like to experiment with different video decoder to see if that fixes the issue.

You may need to restart QGround after selecting an option to apply it.

If that doesn’t work, I would like you to try to use our free tier version of Discovery to see if the problem still persists.


Hi, did you get to look at the video I sent you ?

Yes I did, this appears to be a problem with the decoding part. Our camera uses a more efficient compressing algorithm than the ELP camera that is stock with Blue Robotics but this also means that it requires more work to decode. Can you check the QGround decoder settings first? If that doesn’t work, check with Discovery.


I have now tried the coth cameras with discovery but the problem remains. I then disconnected the camera from the rasberry Pi and installed it intio the topside computer and ran a test using: Webcam Test - Online, Free - VEED
The camera seems to work very well with no latency.
I believe the rasberry pi 4 should be sufficient to operate the camera? The ethernet cable from the rasberry to the topside PC is a 5m CAT6 UTP.

We noticed in our testing that BlueOS initiated cameras streams may cause the behavior you are observing. We would recommend installing DWE OS which is the recommended way to stream cameras, and should allow you to control even more parameters than what BlueOS allows. If you would like help in setting up your environment, please email us at support@dwe.ai and we would be more than happy to help!

1 Like

The thing is that I need to have view the camera on Qground control to also see the OSD on the same screen.

Have you tested the camera on a typical Bluerov set-up and actually got it working? If so, please share which version of ardusub/QGC that was used and how parameters were set up.

BlueOS is always buggy for us when it comes to sending multiple video streams. Even using the stock ELP camera, the stream sometimes just doesn’t appear.

We do have a setup with 7 cameras working on a BlueROV by running DWE OS. I think you are confusing DWE OS with Discovery. You can still view streams sent by DWE OS on QGround. DWE OS sends streams via UDP the same way as BlueOS but the pipeline and the way it manages multiple video seems to be more reliable. :slight_smile:

DWE OS is installed on the Raspberry Pi of the ROV (can be installed alongside BlueOS).

Hope that helps

1 Like

Thank you for this clarifying answer. I did take a look on your document section to learn more about how to install the DWE OS onto the Raspberry Pi. However, it is still not clear to me how to do it correct. Is it possible for you to outline a step-by-step procedure on how to do this without mixing in the various options on how to do it. I am confused whether the OS is installed onto the Pi via the topside computer and ethernet or if the SD card from the Pi need to be pulled out, inserted into the topside computer and flashed, or to use the Pi as a stand alone computer with screen, keboard and mouse, ora combination of those. A plain and simple step-by-step for dummies would be really helpful at this point.

I have tried to adjust the settings as suggested without any changes to the quality
Discovery shows the same bad picture quality…
I am not able to accecc the DWE OS. I have tried to access via Putty. After typing in the username and promted for the PW, nothing happens when trying to to type.
I have also tried to go wia the browser to: []
And: http://companion.local:5000

I have tried both options with and without BlueOS running…

I also formatted the SD card and installed DWE OS only…no sucsess
I then flashed the BlueOS alongside with DWE OS…no sucsess

Cannot access DWE OS, video quality is still poor…

Looks like the latency is gone, but the pixilisation still rmains…badly.
I switch between Blurov usb cam and DWE cam, bluerov works just fine…I just cant wrap my head around this…

Go to to access DWE OS. Disable video streaming on BlueOS first under 5000.

Let me know how that goes

I will try, but then this confuses me