Trouble with connection through raspberry pi and blue-os/QGC

I have encountered a problem getting a videofeed from the exploreHD camera when feeding it through a raspberry pi. It works perfectly when the same cable is connected directly to a computer, but somehow it won’t connect this way. It has worked earlier, although a bad connetion.
I get the following message from the terminal:

Is this something you have seen before?

Thank you in advance.

best regards

Hi there!

I am sorry to see you are having issues with the video feed. Usually these kinds of software issues are related to a physical error with the USB connection (even if it is working on another device, sometimes it is worth checking). Can you send a picture of the soldering done on the exploreHD camera cable? Please make sure you are keeping the white and yellow wires close together for impedance control as well.

The soldering is under shrinkflex, so it’s probably not easy to see. I can remove it if that’s necessary. At the moment we are supplying the camera with a adjustable powersupply to make sure it gets 5 volts.
The picthues might be a little unclear becauce of all the other wiring. It’s the two JST’s beside each other, one is supply from the raspberry the other is to the camera and a fuse between them.

The signal wires are fairly close together and twisted.
We have tried wickling the wire around while connected to the computer, with no connection issues.

could only add one pic.

The camera is now working again, but with a sub optimal connection.

Through a lot of tinkering, trial and error, and retries we have somehow made the connection work fairly stable.
Thank you for the help

Hi there,

Apologies for the delayed response. Having any kind of cuts in the USB data lines and soldering extra extensions on it will always cause issues with impedance matching. I would try to keep the data lines as close together as possible.

Hope that helps :slight_smile:

1 Like