HDcams not recognized by interface through multiplexer


I am an integrating 2 extra cameras to My BlueROV2. I successful installed the DWE OS to the BlueROV Pi. For some reason, I am not getting any feeds on the DWE web Interface other than the BlueROV Camera. The RX and TX from each camera are connected to the multiplexer with the connectors. The HDcams are powered by a different 5V in a different enclosure (I didn’t want to run 6 extra cables for 3 additional instruments). I metered the voltage and they are getting their 5V and each RX and TX cables are properly connected from the camera to the boards. I tried connecting the multiplexer directly to my PC to see if it would recognize it in device manager but it does not recognize any new instruments. I tested the USB-C cable with my phone to make sure it was working. Are there any other tests I could do to figure out if the problem is coming from the board or the HDcams?

Hi there,

That does seem odd. Can you send us a picture of the setup?


In terms of the set up, I recently took the board and cameras off the ROV and made a separate set up with another raspberry pi and spare PiHawk. For troubleshooting purposes I simplified the system and, I now have one camera on the Multiplexer board connected a Pi running BlueOS and the DWE Software.

After a bit of troubleshooting, I was able to get both cameras feeds to work individually with the BlueOS (Cameras directly to the Pi). The issue seemed to be coming from the multiplexer board so I checked the power output. I couldn’t get a voltage reading on the multiplexer board output pins to the cameras. I tried with both the USB-C and with the 5V Input Power using the Pi 5V out. The board is a Multiplexer Board V1.2 so that version does not have a jumper to direct the power source.

Which pins of the Pi are you getting the 5V from? The V1.2 board does not have the jumper directly from USB C but the connector connecting to a Pi should work fine.


The pins used are 4 - 5V and 6 - GND. The board is getting the 5V but its not making it passed the Power Distribution Switch Chip since the output pins are reading in the mV.

As a power saving and over current protection measure, the power only outputs through the USB pins once there is a device connected and in use. So it is normal that there are no 5V going if nothing is connected. Can you send a picture of the setup with the board so we can take a look if its possible there was a connection issue?


So I was able to trace the problem to 10cm of twisted pair cable in my system. I use a cable (lime green cable in photo) to connect the Main Electronics Can to the Battery Can so I can add more sensors on the ROV. I was able to get both cameras to work when connected directly to the board, but it would not work when the twisted pair cable was involved. I then had to test it with another twisted pair cable and sure enough no communication. It was a simple detail that I overlooked. The other sensors in the Battery Can are working fine so I didn’t suspect it could be it.

I will move a sensor from the Main Electronics Can down to the Battery Can and have both cameras connect directly to the board.