Gstreamer problem with setup

Hi. I’m trying to install gstreamer and following the guide from you website.
I have done everything in the correct order and i am in the following step:
To test the gstreamer setup, open CMD and run the following:
gst-launch-1.0 --version

When i type in that command in CMD i just get the following answer in CMD: ‘gst-launch-1.0’ is not recognized as an internal or external command,
operable program or batch file.

How do i fix this??

We recently made a video about setting up gstreamer with OBS. If you follow the video, it should help you diagnose and potentially fix your issue!

If you continue to have issues, please reply back on this thread. We would be more than happy to help!


I actually followed this video when i tried, but got the same result…

If windows command prompt is unable to recognize gst-launch-1.0 --version as a command, this is most likely a PATH issue.

The windows PATH is the location where windows command prompt (CMD) checks for the program path for the gstreamer executable files. I would double check your PATH to make sure it is properly set.

Please utilize the official gstreamer installation instructions to see if it will resolve your issues.