Explore HD2.0 cams not working in OBS


I have two explore HD 2.0 cams that I am looking display in OBS studio. The cameras are both plugged into the DWE 7 port UBS hub, which is plugged into a RPi4 running only DWE OS (no BlueOS or anything like that, just a plain Raspian install).

The RPi4 is set to a static IP of and the PC running OBS is set to I can navigate to in a browser on the PC described above, and I can see the config settings for both cameras. They are both set to h.264 on, UDP on, VBR off. One camera is set to stream to and the other to

I have set my Environmental Path variables as described in the Docs, and I get a positive response when I query the Gstreamer version in a windows command window, so I think I have the Path variables set properly. I can add a Gstreamer source in OBS no problem, but when I put the settings descibed in the DW guide, I can’t see the camera’s stream.

I have tried different Ethernet switches/cables, and have disabled the firewall on the PC running OBS. I should mention, I can see one of the cameras using VLC on this PC, but not the other.

I have also tried this identical setup on a different test PC, and it all worked flawlessly. As far as I can tell, all the settings are the same, with the possible exception of the GStreamer and OBS versions (a few versions older on the test PC that works).

Any thoughts on what to try next would be great.

Thank you,


Hi Ben,

Welcome to the forums!

Here is a video that describes it in details: https://youtu.be/EiFe1Tzbzd8?si=qlDmeVRyUi7EVusE

Though based on your description, I would say you don’t have permissions enabled for firewall to access the streams. Try checking your firewall settings for both OBS and Gstreamer.

Thanks :slight_smile:

Hi @Joseph,

Thanks for that. I had watched the video before and that was helpful. I am using the exploreHD cams on a computer that never connect to the Internet, so I have disabled Firewalls entirely.

I see what you are saying about firewall exceptions for Gstreamer and OBS, but wouldnt that be unecessary if the firewall is disabled entirely?

Second question, should the environmental path variable be set to:


Or, should it be this?:


I guess it not clear to me if I have to point it to the folder gstreamer is in (‘bin’) or gstreamer itself.

Thanks again,


Hi @Joseph,

I set the Environmental variable to the following today:


Can now see both video feeds in Qgrouncontrol when i change between port 5600 and 5601, as expected.

However, still no luck with OBS which is were id like to view the video. Any further suggestions?

I believe im using the latest version of Gstreamer (1.22.5?). Firewalls still fully disabled.



If you are able to get the Gstreamer source to show when you add a source on OBS and you see this:

Then it shows you have installed it properly within Gstreamer. Can you send me the pipeline you are using with OBS?


Hi Joseph,

Thanks for that. I do see the color bars when I try to setup a GStreamer source.

However, still nothing once I click ‘OK’ after seeing the color bards. This is what I see, and the pipeline for the source is shown in the photo below. I have tried it with and without a period after the word ‘video’ at the end of the pipeline, but it does not seem to make a difference:

Let me know if there is anything else you’d like me to check out. Using OBS V. 29.0.2.



Hi Ben,

Go to Windows Defender Firewall and click on Allow an app or feature through Windows Defender Firewall.

Enable both gst-launch and OBS for private and public.

Let me know!

OK, we will try that, but as I’ve stated above the firewall is completely disabled for both Public and private connections. It is my understanding that exceptions should not be needed when the firewall is entirely disabled. Is that correct?



I don’t think that is the case. I think it is worth a try.

Have you had a chance to try it and does it work?

Hi Joseph and Ben,
I’m following this thread in parallel as well with a new ExploreHD camera. Similar issues getting the stream into OBS, but with a BlueROV. I too have gotten to the Multicolored panel so I assumed I installed Gstreamer correctly. I used the pipeline provided in the documentation:

udpsrc port=5601 ! application/x-rtp,media=(string)video,clock-rate=(int)90000,encoding-name=(string)H264 ! rtph264depay ! avdec_h264 output-corrupt=false ! videoconvert ! video.

The Camera is defined as UDP port 5601. While I’m unable to disable my firewall entirely, all ports related to UDP ports 5600, 5601, OBS, QGC and other Blue ROV ports are set to open entirely.

The display in OBS comes up exactly as Ben screen grabbed above. I’ll note the feeds come in fine to the DWE-QGC software. Let me know if you have any insights.

Port 5600 = BlueROV base internal camera
Gstreamer v1.18.1
OBS plugin v3.3
OBS v29.1.3


I think the issue is with QGround interfering with OBS. Can you make sure QGround is set to a different port or maybe close QGround altogether?


Hi Joseph and Mike,

I had to set this one aside for a bit, since I got pulled away on some other tasks.

We don’t have QGroundControl running at the same time, so I don’t think that was the issue.

I am not sure if I mentioned it before, but I did try the identical setup on a different PC at home, and it worked just fine. I was trying to figure out what was different between the two PC’s, but couldn’t come up with an easy answer. Perhaps different versions of OBS and GStreamer?

The PC that I tested it on has slightly older version of GStreamer, and a slightly older version of OBS running. On the computer that it worked on:

OBS: v29.0.2
OBS plugin v0.3.3 (same as @mike.bollinger)
GStreamer v1.22.1

Hope some of that is helpful. Still open to ideas on what to try.


Hi Ben,

I am not sure why it works on one computer but not the other if all firewalls and settings are the same. Contact our team at support@exploredeepwater.com and we can offer a discount on our Discovery software which makes our platform plug and play.