DWE Camera with Nvidia Decoder


I have been playing with the DWE camera in dweQGC, however i have noted that for some reason forcing the Nvidia decoder the quality really falls off, like to an unusable to degree. I don’t quite understand why this is the case, since software is useable. Is there specific nvidia settings i must turn on the get decent quality out of the nivdia decoder?


Hi there :slight_smile:

Could you send us a sample of the quality being off?

Also what are the specs of your computer. Have you tried viewing the stream in OBS to see if the same error occurs?


Screenshot 2022-09-07 104256
this is the example. It will randomly go green of pixilated like that. when is clear it generally has a really bad frame rate on everything in the multivideo context which makes it impossible to use. Main camera is usually ok, occasionally stutters, regardless of the decoder.

also tested on this to the same result

To be clear though, software and direct3d perform pretty well, its mostly just the nvidia decoder. I’ll check through OBS soon.

Hmm, that is odd.

Please check with OBS to see if the same error occurs. Let me check with my team and I will get back to you on that!

i ran it through OBS. Running it through OBS didn’t have the green artifacts and the majority of the video lag, however there still seems to be these noticeable camera dropouts that looked like this

where it tended to hook up on an artifact, double up on an image, then stay on that frame of the image for half a second. This might be noise but I tried a fair amount of things to avoid it so I’m not sure it should be dropping out like it is.

Here is our video when testing with 4 cameras at once. :slight_smile:

We are using a laptop with Nvidia GTX 1080.

Are you running both BlueOS and our DriverUI? Make sure that they are not trying to stream into the same port at the same time if that is the case. Sometimes BlueOS would force streams to start even when they have been deleted so in that case turn it off on the DriverUI side.

Also, if you haven’t already, make sure you update the drivers of your graphics card (decoding H264 video can be quite intensive especially having multiple streams). Ensure that you are using the NVIDIA graphics driver and not the CPU built in one. (check with task manager). Also make sure that your computer is on high performance mode and not power saving.

If the problem only exists when multiple streams are present regardless of the camera, its most likely a problem on the computer end, not the ROV end.

If these solutions don’t solve the problem, contact our support team at support@exploredeepwater.com and we can help you out with teamviewer support! :slight_smile:


With regards to this, are you talking about the BlueOS video manager and the exploreHD driver config?

I did try updating drivers for the card, both studio and game ready. neither seemed to have any effect. PC is definitely on high performance and i have set DWEQGC to use the nvidia graphics card.

Also What bitrate should i be using in the exploreHD Driver Config, that is unclear to me.

Second note, i removed UDP stream from the driver and that fixed the main camera, but the multicam lost frames and messed up visually . maybe i am missing something so i’ll send through that email.

Yes, I was referring to the BlueOS video manager and the exploreHD driver config. Running 2 of them can cause conflict as they are trying to access the same port. Normally I would suggest disabling the BlueOS one because its not as stable and harder to start the stream but the delete button doesn’t work well so I would disable the stream on the exploreHD driver config. You can still adjust bitrate even without the stream there. I would set it to 10Mb/s which should be the default as a nice compromise between image quality and bandwidth.