Cannot start firmware updater

Hi there,

I am trying to update the firmware on my exploreHD camera, but I get an error when starting the .exe file.
“The application could not be started correctly (0xc000007b). Click ‘OK’ to close the application.”
What could be wrong?

Additional notes:

  • I have extracted the zip file into my Downloads folder.
  • I am logged in as admin on my Windows 10 laptop.
  • I can see the the video fine using the Windows Camera app (and I close the app before starting the updater).
  • I have deactivated my laptop’s built-in webcam using the Device Manager.

Thank you!



Hi there!

I am sorry you are experiencing issues with the firmware updater.

There are two main possibilities I see:

  • You may be running on 32-bit windows
  • The zip file may not be extracted correctly so make sure you are not running the file from inside the zip

I suggest to try a different computer if you cannot verify any of the above possibilities.

Please reply with any updates and have a nice day! :smiley:


Thank you @Brandon for your fast reply!
I can confirm that I am running the latest Windows 10 (21H1) with 64 bit.
After downloading the zip file, I extracted it to my Downloads folder using the tool that comes with Windows Explorer. In my Downloads folder, I now have a normal folder called “DWEFirmwareUpdater”. This folder contains another folder with the same name, and in that folder, I have the five files that are shown in the video.

I’m in the office today so I can ask my colleague if he can try it on his laptop. Will keep you updated.


Hi @Brandon ,

I managed to get it to work on another laptop and I am not quite sure why.
It worked on a Dell Latitude with Intel i5 CPU on Windows 10 Version 20H2. (Edit: I just updated this laptop to 21H1 and it still worked.)
It did not work on a Lenovo Thinkpad with Intel i9 CPU on Windows 10 Version 21H1.

Feel free to contact me if you need more details to analyse the problem in the future. :slight_smile:


@monsterbacke, glad you managed to get it working!

Thank you for providing the details on the problem, we will do further research into exploring the bug in the future.

Given the fact it still works on the Dell Latitude even when being updated, I can suspect it can be due to an issue with the Thinkpad and its compatibility, or possibly its setup as it could have a different set of libraries (although I’m not quite sure how that would happen).

If you do manage to get the firmware updated on the Thinkpad, definitely send a reply as that could give some info into what might have gone wrong.